Use of unresolved identifier ‘FirebaseApp’

久々に Podfile を更新した際、Use of unresolved identifier ‘FirebaseApp’ というエラーが発生しました。
見るからに Firebase 関連のエラーっすね。
解決方法はシンプルなので、ぜひこの記事で解決して下さい (・ω・)

前提条件

・Xcode11.6
・Swift5
・Firebase はPod管理

解決方法

エラー発生した更新方法

普通にターミナルで更新しました。

私の場合、更新ファイルが Firebase 関連だけでしたが、5分ほどかかりました。
いつもより長ぇ…終わらねぇ…って方は少し待ってみるといいと思います。

import ファイル修正

Firebase を import しているファイルをいじります。

これでビルドしたらエラーが消えてると思います。

さいごに

Podfile 更新したあとに出るエラーって、稀に謎エラー発生するからテンション下がるけど、これはシンプルでよかった (´・ω・`)

コメント